注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

幸福边缘

紫枫

 
 
 

日志

 
 

Project facet Java version 1.7 is not supported.问题  

2013-11-20 14:54:17|  分类: 技术相关 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

eclispe无法运行java web程序—提示:Project facet Java version 1.7 is not supported

分类: 【J2SE】 2012-03-12 16:30 6100人阅读 评论(7) 收藏 举报

javawebfacettomcathibernatejdk

   重装eclispe,重新配置tomcat,在eclispe中配置tomcat。配置一切顺利,配置完毕检验。

   新建java web程序,然后进行测试。

   在eclispe中,新建java web 程序,结果如下:

  

   请注意看程序上的红点。怎么会无缘无故中多出一个红点来呢?现在只是新建一个程序而已,还没有添加任何文件或代码呢,整体查询一下,也没有报错啊。因为原来的web程序如下:

  

   没有红点啊。这是怎么回事。因为重装了eclispe后,安装了Hibernate tools插件。难道是插件的原因?疑惑。然后继续进行测试。当运行这个web程序时,无法运行,提示错误如下:

  

   当时安装的tomcat是tomcat7版本,安装的jdk版本是1.6。

  

   配置的tomcat如下:

   window-Preferences-Server-Runtime Environment,添加tomcat。如下:

  

   检查多次,tomcat安装,环境配置,都没问题,那就把目标问题锁定在安装上了,在配置tomcat中,当选择jre时,选择自己安装的,而不是系统默认的。这样选择是正常的,但是当点击Installed Jres时,结果如下:

   看到这个问题,原来才发现问题的真正所在在于此啊。安装的jre是1.6的。但是1.7是啥东西啊?1.7是怎么出来的呢?

  

   然后经过一翻查询,终于知道了1.7的出处了。同时也解决了此问题。解决办法如下:

   Window-Preferences-java-Compiler中:终于看到了1.7的影子。在此,改成自己对应的jdk版本。我的是1.6,直接改成1.6即可。

  

   更改后,一般不会立即生效,需要重启eclispe。web程序图标恢复原来的模样,并且运行正常。OK,一切,搞定。继续学习哈~

  评论这张
 
阅读(1590)| 评论(1)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017